Jun 30

TSM for Databases – All Requirement Documents

SQL, TDP Comments Off on TSM for Databases – All Requirement Documents

Version 7.1.2

Version 7.1.2 was announced on April 14, 2015 and will be available for download on April 17, 2015. Information regarding how and where to download 7.1.2 will be available here:
http://www.ibm.com/support/docview.wss?uid=swg24039480 on the download availability date.

—————————————————————-

Version 7.1.1

The version 7.1.1 Fix Pack was announced on September 2, 2014 and will be available for download on September 12, 2014. Information regarding how and where to download 7.1.1 will be available here: http://www.ibm.com/support/docview.wss?uid=swg24038212 on the download availability date.

—————————————————————-
Version 7.1

Version 7.1 was announced on October 29, 2013 and will be available electronically on December 13, 2013.
—————————————————————-

Version 6.4.1

  • Data Protection for Oracle was not updated to the 6.4 level. Please refer to the 6.3.x HW & SW requirements link listed below

—————————————————————-

Version 6.4

Version 6.4 was announced on October 3, 2012 and will be available electronically on November 16, 2012.

—————————————————————-

Version 6.3.1

 

      The V6.3.1 Fix Pack was delivered to the public FTP site on December 18, 2012.

 

      This fix pack includes:

      • APAR fixes
      • Toleration level support for Windows 2012 Server
      • Toleration level support for Microsoft SQL Server 2012.

Note:

    The exploitation of new features available with Windows 2012 Server and Microsoft SQL Server 2012 is available in the Version 6.4 release.

—————————————————————-

Version 6.3

—————————————————————-
Version 5.5.6
TSM for Databases 5.5 has reached end of support via some product offerings. Please refer to the following tech note for additional information: http://www-01.ibm.com/support/docview.wss?uid=swg21665620

 

The V5.5.6 Data Protection for SQL Fix Pack was delivered to the public FTP site on September 5, 2012.

—————————————————————-

Version 5.5.5

TSM for Databases 5.5 has reached end of support via some product offerings. Please refer to the following tech note for additional information: http://www-01.ibm.com/support/docview.wss?uid=swg21665620
The V5.5.5 Data Protection for SQL Fix Pack was delivered to the public FTP site on December 10, 2010.

—————————————————————-

Version 5.5.4

TSM for Databases 5.5 has reached end of support via some product offerings. Please refer to the following tech note for additional information: http://www-01.ibm.com/support/docview.wss?uid=swg21665620

Available: June 4, 2010

Data Protection for Microsoft SQL Server released a V5.5.4 Fix Pack. This document contains the updated V5.5.4 hardware and software requirements.

Changes to DP for SQL 5.5.4:

  • APAR fixes for all platforms
  • Support for SQL backup compression option available with SQL Server 2008
  • Backup & Query performance improvements for Microsoft SQL Server environments that contain a large number of SQL databases
  • Expansion of Instant Restore support from SE target volumes for SVC 5.1

—————————————————————-

Version 5.5.3

TSM for Databases 5.5 has reached end of support via some product offerings. Please refer to the following tech note for additional information: http://www-01.ibm.com/support/docview.wss?uid=swg21665620
TSM for Databases was updated on October 23, 2009 to include the following updated components:

  • Data Protection for SQL V5.5.3

Changes to DP for SQL 5.5.3:

  • APAR fixes for all platforms
  • Support for SVC 4.3

—————————————————————————————–

Version 5.5.2

TSM for Databases 5.5 has reached end of support via some product offerings. Please refer to the following tech note for additional information: http://www-01.ibm.com/support/docview.wss?uid=swg21665620

TSM for Databases was updated on June 12, 2009 to include the following updated components:

    • Data Protection for Oracle V5.5.2

Changes for DP for Oracle 5.5.2:

    • Added Oracle 11g for Windows 2008 support
    • Added Asianux 3.0 support

TSM for Databases was updated on November 26, 2008 to include the following updated components:

    • DP SQL V5.5.2 PTF

—————————————————————————–

Version 5.5.1

TSM for Databases 5.5 has reached end of support via some product offerings. Please refer to the following tech note for additional information: http://www-01.ibm.com/support/docview.wss?uid=swg21665620
TSM for Databases was updated on July 3, 2008 to include the following updated components:

  • Data Protection for Microsoft SQL V5.5.1

 

Changes for DP for SQL 5.5.1:

 

    Added Windows 2008 support

 

The initial release of TSM for Databases V5.5.1 (available) April 17, 2008) contained:

  • Data Protection for Oracle V5.5.1
  • Data Protection for Microsoft SQL V5.5.0.

 

Changes for DP for Oracle 5.5.1:

 

      Added Oracle 11g support

Added support for the following OS / platforms:

 

        RHEL 4 on Linux Itanium RHEL 5 on Linux Itanium, Linux x86_64, and Linux x86

SLES 9 on Linux Itanium SLES 10 on Linux Itanium, POWER, and z64

HP11iv3 for PA-RISC and IA64 AIX 6.1

Added:

  • An option to Indicate whether backup objects are encrypted
  • Logging throughput statistics
  • New product installer

 

—————————————————————————–

Version 5.5.0

TSM for Databases 5.5 has reached end of support via some product offerings. Please refer to the following tech note for additional information: http://www-01.ibm.com/support/docview.wss?uid=swg21665620

 

TSM for Databases V5.5.0 contains:

  • Data Protection for Microsoft SQL V5.5.0
  • Data Protection for Oracle V5.4.1

The hardware and software support requirements for Data Protection for Microsoft SQL have been updated to reflect the Version 5.5.0 release.

Changes: To see a list of enhancements for this release, please refer to US Announcement Letter 207-290. This package is on Passport Advantage.

written by Bosse

Jun 26

Hardware and Software Requirements: Data Protection for VMware Version 7.1.2

Info, VE Comments Off on Hardware and Software Requirements: Data Protection for VMware Version 7.1.2

Abstract

This document details the Hardware and Software requirements for Tivoli Storage Manager for Virtual Environments: Data Protection for VMware 7.1.2.

Content

The Data Protection for VMware requirements vary by high level functional component. Data Protection for VMware has the following high level functional components:

  • Data Protection for VMware GUI
  • Data Mover
  • Recovery Agent

Note:
All Data Protection for VMware functional components must be at the same Fix Pack level. Within a given Fix Pack level, the interim fix level can differ.

Examples:

  • When upgrading the Data Protection for VMware GUI from 7.1.1 to 7.1.2, all Data Movers and recovery agents must be upgraded to 7.1.2.
  • When upgrading a Data Mover from 7.1.1.1 to 7.1.1.2, it is not required that all other components be upgraded to 7.1.0.2 (but they all must be at 7.1.1.x).

This document is divided into linked sections for ease of navigation. You may use the links below to jump to the desired section of the document.

Supported VMware vSphere versions

Supported VMware vCloud Director versions

Data Protection for VMware GUI supported operating systems

Data Mover supported operating systems

Recovery Agent & Recovery Agent Command Line Interface supported operating systems

Mount proxy supported operating systems

Additional software requirements and limitations

Hardware requirements for Data Protection for VMware

Where to download Tivoli Storage Manager for Virtual Environments 7.1.2

Hardware and Software requirements for other releases of Data Protection for VMware

Supported VMware vSphere versions

The following VMware vSphere versions are supported:

  • vSphere 5.1
  • vSphere 5.5
  • vSphere 6.0

Attention: ESXi 5.1 hosts must be at Update 3 or newer patch or update level. ESXi 5.5 hosts must be at Patch 4 or newer patch or update level. These prerequisite levels address a critical VMware Changed Block Tracking (CBT) integrity issue described in VMware KB 2090639.

Note:

  1. The Data Protection for VMware GUI “IBM Data Protection” extension requires vSphere Web Client version 5.5 update 1 (or later). Update 1 is included in the vSphere 5.5 package.
  2. To view supported vSphere and ESXi host versions, please refer to the following tech note: “Tivoli Storage Manager for Virtual Environments: Data Protection for VMware Data Mover compatibility guide with VMware’s Virtual Disk Development Kit”http://www.ibm.com/support/docview.wss?uid=swg21672351

Supported VMware vCloud Director versions

The following VMware vCloud Director versions are supported:

  • vCloud Director 5.1
  • vCloud Director 5.5

Data Protection for VMware GUI supported operating systems

This functional component integrates the product with the VMware vSphere client in order to back up, restore, and manage virtual machines in the VMware vCenter and includes the Data Protection for VMware command-line interface.

The supported operating systems by platform are detailed below.

Linux x86_64 platform

The following operating systems are supported for the Data Protection for VMware GUI on the Linux x86_64 platform.

  • Red Hat Enterprise Linux (RHEL) 5 Update 6 and later maintenance levels and mod levels: Desktop, Advanced Platform and Server Editions
  • Red Hat Enterprise Linux (RHEL) 6, and later maintenance levels and mod levels: Server Edition
  • Red Hat Enterprise Linux (RHEL) 7, and later maintenance levels and mod levels: Server Edition
  • SUSE Enterprise Linux 11, and later mod levels and Fix Packs: Server Edition

Windows x64 platform

The following operating systems are supported for the Data Protection for VMware GUI on the Windows x64 platform:

  • Windows Server 2008, and later maintenance levels: Standard, Enterprise, Datacenter Editions
  • Windows Server 2008 R2, and later maintenance levels: Standard, Enterprise, Datacenter Editions
  • Windows Server 2012 and later maintenance levels: Essentials, Standard, and Datacenter Editions
  • Windows Server 2012 R2 and later maintenance levels: Essentials, Standard, and Datacenter Editions

Note: Data Protection for VMware GUI provides support for Windows Storage Server 2012 for functionality that is also available and supported by the Data Protection for VMware GUI on the Windows Server 2012 Editions.

Data Mover supported operating systems

The Data Mover is installed on the vStorage Backup Server and enables off-host block level incremental backups. This function is enabled by the installation of the Tivoli Storage Manager (TSM) Backup-Archive Client 7.1.2, and later maintenance levels and Fix Packs. The TSM Backup-Archive Client is a separate prerequisite and is included as a convenience in the Data Protection for VMware 7.1.2 installation package. For Windows it may optionally be installed during TSM for Virtual Environments installation. The TSM Backup-Archive Client may also be downloaded independently – see below for details on additional software requirements and limitations.

Though the TSM Backup-Archive Client supports a wide variety of operating systems, only a subset of those operating systems are supported with TSM for Virtual Environments.

  • The 7.1.2 level of the TSM Backup-Archive client, and later Interim fixes of this Fix Pack, is required with Data Protection for VMware 7.1.2.

WARNING :
The TSM Client API 7.1.2 is also a prerequisite of Data Protection for VMware 7.1.2 and on Windows it is automatically installed as a part of the Data Protection for VMware 7.1.2 installation process. The TSM Backup-Archive Client 7.1.2 is a prerequisite to using the Data Mover function for off-host block level incremental backups. The TSM Backup-Archive Client and TSM Client API levels must remain in sync in your complete environment. Therefore, future updates to either the TSM Backup-Archive Client or the TSM Client API require the other component to be updated at the same time. I.e. if you install a new Fix Pack level of the TSM Backup-Archive client, you need to upgrade the TSM Client API to the exact same level on your Data Protection for VMware systems and vice versa. See also ” Upgrading to Tivoli Storage Manager for Virtual Environments Version 7.1.2

The VMware Virtual Disk Development Kit (VDDK) version 6.0 runtime files are used for backing up virtual machines by the Data Mover. Data Mover / TSM Backup-Archive Client with Data Protection for VMware supports the operating systems listed below, as long as they are also supported by VDDK version 6.0. For updates on supported OSes, known issues and limitations regarding VDDK 6.0 see the VMware web site.

The Data Protection for VMware Data Mover utilizes VMware’s Virtual Disk Development Kit (VDDK) API’s to open, close, read and write virtual disk data (VMDKs). To determine the level of VDDK used in each level of Data Protection for VMware, as well as compatible ESX/ESXi builds supported by the VDDK level, please refer to the tech note:
Tivoli Storage Manager for Virtual Environments: Data Protection for VMware Data Mover compatibility guide with VMware’s Virtual Disk Development Kit
located here http://www.ibm.com/support/docview.wss?uid=swg21672351

The supported operating systems by platform for the Data Mover / TSM Backup-Archive Client with Data Protection for VMware are detailed below.

Linux x86_64 platform

The following operating systems are supported for the Data Mover on the Linux x86_64 platform:

  • Red Hat Enterprise Linux (RHEL) 6 Update 6: Client and Server Editions
  • Red Hat Enterprise Linux (RHEL) 7.0: Client and Server Editions
  • SUSE Enterprise Linux 11 SP3: Desktop and Server Editions
  • SUSE Enterprise Linux 12: Desktop and Server Editions

Windows x64 platform

The following operating systems are supported for the Data Mover on the Windows x64 platform:

  • Windows Server 2008 R2: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
  • Windows Server 2012 Essentials, Standard, and Datacenter Editions
  • Windows Server 2012 R2 Essentials, Standard, and Datacenter Editions

Note: Data Mover provides support for Windows Storage Server 2012 for functionality that is also available and supported by Data Mover on the Windows Server 2012 Editions.

Recovery Agent supported op erating systems

This function provides virtual mount and instant restore capabilities. The supported operating systems by platform are detailed below.

Linux x86_64 Platform

The following operating systems are supported for the Recovery Agent on the Linux x86_64 platform:

  • Red Hat Enterprise Linux (RHEL) 51 Update 2, and later maintenance levels and mod levels: Desktop and Advanced Platform Editions
  • Red Hat Enterprise Linux (RHEL) 61, and later maintenance levels and mod levels: Client and Server Editions
  • Red Hat Enterprise Linux (RHEL) 7: Client and Server Editions
  • SUSE Enterprise Linux 11, and later maintenance levels and mod levels: Desktop and Server Editions
  • SUSE Enterprise Linux 12, and later maintenance levels and mod levels: Desktop and Server Editions


Note:

  1. Requires the following minimum packages and their dependencies:
  • compat-db-4.6.21-15
  • libXp-1.0.0-15.1
  • libXmu-1.0.5-1
  • libXtst-1.0.99.2-3
  • pam-1.1.1-4
  • libXft-2.1.13-4.1
  • gtk2-2.18.9-4
  • gtk2-engines-2.18.4-5

The Recovery Agent Command Line Interface (CLI) is not supported on the Linux x86_64 platform.

Windows x86 Platform

The following operating systems are supported for the Recovery Agent on the Windows x86 platform:

  • Windows Server 2008 SP1, and later maintenance levels: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
  • Windows 7, and later maintenance levels: Enterprise, Home Premium, Professional, Starter, and Ultimate Editions
  • Windows 8, Professional and Enterprise Editions
  • Windows 8.1, Professional and Enterprise Editions


Note:
If you use Active Directory with Microsoft Windows 2008 or Microsoft Windows 2008 R2, install the hot fix associated with Microsoft Knowledge Base article 970770 at:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;970770

Windows x64 Platform

The following operating systems are supported for the Recovery Agent on the Windows x64 platform:

  • Windows Server 2008 SP11, and later maintenance levels: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
  • Windows Server 2008 R21, and later maintenance levels: Standard, Enterprise, Datacenter, Storage Server, Storage Server R2, Small Business Server, Essential Business Server, and Web Editions
  • Windows 7, and later maintenance levels: Enterprise, Home Premium, Professional, and Ultimate Editions
  • Windows 8, Professional and Enterprise Editions
  • Windows 8.1, Professional and Enterprise Editions
  • Windows Server 20122 Essentials, Standard, and Datacenter Editions
  • Windows Server 2012 R22 Essentials, Standard, and Datacenter Editions


Notes:

  1. If you use Active Directory with Microsoft Windows 2008 or Microsoft Windows 2008 R2, install the hot fix associated with Microsoft Knowledge Base article 970770 at: http://support.microsoft.com/default.aspx?scid=kb;EN-US;970770
  2. Recovery Agent & Recovery Agent Command Line Interface plug-in provides support for Windows Storage Server 2012 for functionality that is also available and supported by Recovery Agent & Recovery Agent Command Line Interface on the Windows Server 2012 Editions.

Mount proxy supported operating systems

A mount proxy represents the Linux or Windows system that provides access to virtual machine disks and requires an iSCSI connection. Mount proxy systems are required when using the Data Protection for VMware vSphere GUI Mount wizard (introduced in Version 7.1.1) to mount a backed up virtual machine disk. The user has the option to automatically create shares (either CIFS or NFS) of the mounted volumes for a file-level restore operation.

When mounting a Windows virtual machine, a Windows mount proxy system is required. When mounting a Linux virtual machine, a pair of Windows and Linux mount proxy systems is required.

For a Linux mount proxy system, the following applications must be installed and configured:

  • Tivoli Storage Manager Backup-Archive client Version 7.1.2.

Note: The iSCSI service must be configured and running during the virtual machine disk mount operation and the file-level restore operation.
By default, the iSCSI service is started manually. If the system where this service is running restarts, the iSCSI service must be restarted manually.

For a Microsoft Windows mount proxy system, the following applications must be installed and configured:

  • Tivoli® Storage Manager Backup-Archive client Version 7.1.2.
  • Tivoli Storage Manager for Virtual Environments Version 7.1.2: Tivoli Storage Manager recovery agent.

Note: The iSCSI Initiator service must be running during the virtual machine disk mount operation and the file-level restore operation.
By default, the iSCSI service is started manually. If the system where this service is running restarts, the iSCSI service must be restarted manually.

Data Protection for VMware requires the following operating system levels as mount proxy systems:

Linux x86_64 platform

  • Red Hat Enterprise Linux (RHEL) 6 Update 3 and Update 4: Client and Server Editions
  • Red Hat Enterprise Linux (RHEL) 7: Client and Server Editions
  • SUSE Enterprise Linux 11 SP3: Desktop and Server Editions
  • SUSE Enterprise Linux 12 : Desktop and Server Editions

Windows x64 platform

  • Windows Server 2008 R2: all Editions
  • Windows Server 2012 all Editions
  • Windows Server 2012 R2 all Editions

Additional software requirements and limitations

The following additional software is required to use Data Protection for VMware:

  • Tivoli Storage Manager (TSM Server) 6.2 and later interim fixes and Fix Packs
  • Tivoli Storage Manager (TSM Server) 6.3 and later interim fixes and Fix Packs
  • Tivoli Storage Manager (TSM Server) 7.1 and later interim fixes and Fix Packs

TIP: TSM Client/API and Server compatibility information is located in the IBM Tivoli Storage Manager Server/Client Compatibility and Upgrade Considerations tech note located here:
http://www.ibm.com/support/docview.wss?uid=swg21053218

  • Tivoli Storage Manager (TSM) Server 6.3.4, and later maintenance levels, Fix Packs, releases, and versions is required for use of following features that are new to Data Protection for VMware 7.1:
    • Show VMs with a backup report
    • Show failures from the most recent backup report
    • Show all backup failures report
    • Show backup history view
    • Show all history view
    • Show failed VMs view
    • Show all VMs view
  • Tivoli Storage Manager (TSM) Server 7.1.0, and later maintenance levels, Fix Packs, releases, and versions is required for use of the following features that are new to Data Protection for VMware 7.1:
    • Application protection reporting

Data Protection for VMware components support or require the following applications:

  • The Recovery Agent and Data Protection for VMware GUI require the following supporting applications on Linux:
    • Perl version 5
    • mdadm 2.6 tool for managing Linux Software RAID arrays
    • iSCSI Initiator 6.2 for Linux package
    • lsscsi command version 0.23
    • iscsiadm utility 0.10
    • Secure Shell (SSH) client for Linux 0.1
  • The following browsers are supported with the Data Protection for VMware GUI
    • Microsoft Internet Explorer version 9, 10 or 11 on Windows
      If launching the Data Protection for VMware GUI as a plug-in from the VMware vSphere Desktop Client, Microsoft Internet Explorer version 9, 10 or 11 must be installed on the system where the desktop client is installed.
      Note: vSphere Desktop Client plugin is not supported with vSphere 6.0
    • Google Chrome 13 or later on Windows and Linux
    • Mozilla Firefox 10 Extended Service Release or later on Windows and Linux
  • Application protection for VM guests is supported:
    • on the vStorage Backup server for the following platforms:
      • Microsoft Windows 2008 (64-bit)
      • Microsoft Windows 2008 R2 (64-bit)
      • Microsoft Windows 2012 (64-bit)
      • Linux 64-bit platforms
      • VMware ESX 5.x or later (Windows, Linux)
    • for the following applications:
      • Microsoft Exchange Server 2010
      • Microsoft Exchange Server 2013
      • Microsoft SQL Server 2008 (64-bit)
      • Microsoft SQL Server 2008 R2
      • Microsoft SQL Server 2012
      • Microsoft SQL Server 2014

Hardware requirements for Data Protection for VMware

Hardware requirements vary and depend on the following items:

  • Number of protected servers
  • Number of protected volumes
  • Data set sizes
  • LAN and SAN connectivity

The following table describes the hardware requirements that are needed to install Data Protection for VMware.

Component Minimal requirement Preferred
System IntelPentium D 3 GHz Dual Core processor or compatible Not applicable
Memory 2 GB RAM, 2 GB virtual
address space
Not applicable
Available hard disk 200 MB for ‘Documents and
Settings’ folder
2 GB
NIC Card 1 NIC – 100 Mbps 1 NIC – 1 Gbps

Where to download Tivoli Storage Manager for Virtual Environments 7.1.2

The Tivoli Storage Manager for Virtual Environments download document provides information about how and where to obtain the Tivoli Storage Manager for Virtual Environments 7.1.2 package. The information is located at: http://www.ibm.com/support/docview.wss?uid=swg24039450

TIP: Data Protection for VMware 7.1.2 is a component of Tivoli Storage Manager for Virtual Environments 7.1.2

Hardware and Software requirements for other releases of Data Protection for VMware

The Hardware and Software requirements for other releases and Fix Packs for all Tivoli Storage Manager Data Protection for Virtual Environment components are located in the “Tivoli Storage Manager for Virtual Environments – All Requirements Doc” located at:
http://www.ibm.com/support/docview.wss?uid=swg21505139

Related information

All Requirements Doc
Download Tivoli Storage Manager for Virtual Environment

written by Bosse